Strange Video Colours on XBox

May 7, 2008 at 2:11 PM
When I run any videos on the XBOX with scurvy media, even the small example video provided, the colours appear like they were encoded wrong (Vibrant strange colours show). Any ideas?Works perfect on PC.
This happens when using compression on or off. Tested with playback type stream. Encoded some other videos with cvid format with no compression and got same result.
Coordinator
May 9, 2008 at 4:52 PM
I'm going to check this out in more detail over the weekend. But I'll give a note that the color calibration of your display (ie. TV vs. Monitor) will have a huge impact over how the video's colors look.
May 10, 2008 at 10:46 AM


joelmartinez wrote:
I'm going to check this out in more detail over the weekend. But I'll give a note that the color calibration of your display (ie. TV vs. Monitor) will have a huge impact over how the video's colors look.


I am displaying the 360 on a monitor through VGA analog input. Will try it out on a TV tomorrow.
Can't screen shot on XBox obviously but tried to show you what it looks like through Photoshop.
Image kind of like this
Coordinator
May 19, 2008 at 4:14 PM
just wanted to give you a heads up that I was able to reproduce this issue and am working to resolve it.
May 22, 2008 at 7:06 AM
Thanks for the update. Are there any options / formats I can set that would allow correct xbox playback currently? I ask because I am submitting my project onto the xna creators club tomorrow.
May 22, 2008 at 7:10 AM
Edited May 22, 2008 at 7:10 AM
D.P.
May 22, 2008 at 11:58 PM
I've also encountered this problem, just so you know it's not isolated.
Coordinator
May 23, 2008 at 1:07 PM
I fixed it!!!! :-D  haven't had a chance to put together a formal release, but if you need it now you can download the source and compile it.  I should be putting together a formal release and adding it to this site over the weekend.

thanks for all your patience and feedback so far ... you guys are great :-)
May 25, 2008 at 11:31 AM
Cool! can't seem to build source though as missing PlatformSurface.cs
I will wait for the formal release with compiled dlls. Thanks again.
Coordinator
May 25, 2008 at 4:21 PM
My mistake, I apologize ... the TFS client for visual studio for some reason did not include it when I checked in.  I have now uploaded it.  I am putting the release together today and I should have it out either today or tomorrow :-)
May 26, 2008 at 3:14 PM
Got it to compile but ran into trouble when I turned compression on for the video. Would it be possible to upload just the Scurvy.Media.Pipeline.dll and Scurvy.Media.dll built for xbox and a separate pair for PC sectioned off in the release as I must be doing something wrong when linking.
Coordinator
May 26, 2008 at 4:07 PM
Yes, compression is still a bit screwy ... I hope to be working on that for the next release.  In the meantime, if you check the release section, you will find the official release v0.7.2008.0525 :-)  it contains as you requested separate pipeline and runtime assemblies for each platform.

Please let me know if you encounter any further issues.
Jul 12, 2008 at 2:12 PM
Will compression issue be fixed soon? Thinking of using scurvy media but can't have big file size.